Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The following command:

lftp -c 'open -e "set ftps:initial-prot ""; \
set ftp:ssl-force true; \
set ftp:ssl-protect-data true; \
set ssl:verify-certificate no; \
nlist ; " \
-u "username","password" \
ftps://server.domain.org:21'

Produces:

nlist: Fatal error: gnutls_handshake: A record packet with illegal version was received.

Running LFTP 3.7.11. Anyone have an idea what could cause this? I think I may need lftp with gnutls, but installing from source is not really an option on this server, and the only version I see available with yum includes only ReadLine.

# lftp -v
LFTP | Version 3.7.11 | Copyright (c) 1996-2009 Alexander V. Lukyanov
...
Libraries used: Readline 5.1
share|improve this question
    
This is not a question. – Adrian Frühwirth May 8 '13 at 20:38
    
Whoops, didn't realize it didn't paste my whole thing. – Derek May 8 '13 at 20:42
    
According to RFC 4127, the data channel protection (set via the PROT command) must be C (Clear) or P (Protected). You configure lftp to use set ftps:initial-prot ""; you might instead try set ftps:initial-prot "P". – Castaglia Apr 30 at 15:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.