Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to make it easier for users in a small office network environment to connect to an office server running Windows Server 2003. Currently, users map network drives using \IP_ADDRESS\DRIVE. What do I need to do to map by server name instead of IP address?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You will need some kind of internal DNS service for your network - if you already run Active Directory, you will already have this set up.

If not, you can install the DNS components of Windows Server 2003 (see http://support.microsoft.com/kb/814591) or you may be able to use your existing office router for internal DNS if it's capable.

Once you have DNS installed and configured and your server's address entered, you can then try to ping the target server from the workstation, of the ping succeeds, you can proceed to add the share mapping.

share|improve this answer
    
I recently configured my DNS with a forward and reverse lookup zones. nslookup returns Default Server: nfs01.nfs01.local. Not sure where to go from here. Ping succeeds if I use ping nfs01.nfs01.local. –  user1766888 May 8 '13 at 22:58
    
ideally you'd use your organisation name for the domain - i.e. mycompany.local - so your server's FQDN (fully-qualified domain name) would be nfs01.mycompany.local. In any case, you can use the name nfs01 to map your share (your computer will automatically resolve the name to the IP). –  Craig Watson May 8 '13 at 23:03
    
Just tried mapping it from another client but \\nfs01\share_folder returns "Windows cannot access \\nfs01\share_folder" Unfortunately, I'm given a half baked server to work with and I'm still not sure of everything that is/isn't configured :( –  user1766888 May 8 '13 at 23:08
    
Just a quick sanity-check: is nfs01 the server you're actually trying to share from? You'll also need to check that the DNS server can actually resolve the name (e.g. 'nslookup nfs01' - your 'Default Server' line just tells you which DNS server is being used to try to resolve the query, it's the output below this that you're interested in. See this link for more details: support.microsoft.com/kb/200525 –  Craig Watson May 8 '13 at 23:13
1  
Use the fully qualified domain name \\nfs01.nfs01.local\share instead of just the hostname component. If you want to use just the hostname component then adjust your DHCP server to push option 015 with a value of nfs01.local. –  Zoredache May 8 '13 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.