Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I upgraded debian to wheezy and got errors with mysql-server so I removed it. Now I can't reinstall it. I get:

$ sudo apt-get install mysql-server
...
Unpacking mysql-server (from .../mysql-server_5.5.30+dfsg-1.1_all.deb) ...
Processing triggers for man-db ...
gdbm fatal: malloc error
Setting up mysql-server-5.5 (5.5.30+dfsg-1.1) ...
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
...
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
$ 

(Full output at http://pastebin.com/7WpSEDbx)

Notice the somewhat worrying gdbm fatal: malloc error.

How do I get mysql back?

share|improve this question
    
I'm having exactly the same problems. I did a apt-get dist-upgrade (and battled through replacing libc errors) and discovered mysql-server-5.0 and mysql-server-5.1 removed from the system. Tried to apt-get install mysql-server-5.5 and got problems. Tried running mysqld and got a stack backtrace and signal 6. Every time I dist-upgrade Debian something always f@$#s up, last time it was Apache with a change to SSL configs. Giving up and going to build MariaDB from source because I don't trust Oracle not to f@#$ up mysql. –  PP. Jun 19 '13 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.