Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am receiving the following error using a puppet module on my Puppet master to manage both master (Apache / Passenger) and agent

[ashinn@puppet1 ~]$ sudo puppet agent --test
Info: Retrieving plugin
Info: Loading facts in /var/lib/puppet/lib/facter/os_maj_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/ip6tables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/concat_basedir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/iptables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Must pass puppet_server to Class[Puppet::Agent] at /etc/puppet/environments/production/modules/puppet/manifests/init.pp:181 on node puppet1.mydomain.com
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

The node definition for puppet1.mydomain.com is pretty simple:

node 'puppet1.mydomain.com' {
  include motd
  include ntp

  class { 'puppet' :
    puppet_server    => 'puppet.mydomain.com',
    version          => 'latest',
    master           => true,
    agent            => true,
    autosign         => '$confdir/autosign.conf',
    manifest         => '$confdir/environments/$environment/manifests/site.pp',
    modulepath       => '$confdir/environments/$environment/modules',
    puppet_passenger => true,
  }
}

The specific module and init.pp are at https://github.com/olindata/puppetlabs-puppet/blob/master/manifests/init.pp. Line 181 contains the closing } for the 'class { puppet::master:` statement.

I can see that the init.pp does pass puppet_server to the puppet::agent class:

  if $agent {
    class {'puppet::agent':
      version                   => $version,
      puppet_defaults           => $puppet_defaults,
      puppet_agent_service      => $puppet_agent_service,
      puppet_server             => $puppet_server,
      environment               => $environment,
      puppet_conf               => $puppet_conf,
      puppet_agent_name         => $puppet_agent_name,
      package_provider          => $package_provider,
      reporting                 => $reporting,
      user_id                   => $user_id,
      group_id                  => $group_id,  
    }
  }

WHat could be wrong? Am I missing something obvious here?

share|improve this question
    
can you please pastebin your whole init.pp please? –  Danila Ladner May 9 '13 at 22:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.