Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install SLES (SuSE Linux Enterprise Server) SP 1 onto a server but I'm having an issue with the bootloader.

I go through the install, more a less default options except Gnome Desktop is not installed and the OS appears to install without issue until the boot loader. When I then get the error An error occurring during bootloader installation. Do you want to try again?.

If I say yes it then takes me to the Boot Loader option but I can't see any issues so I say finish but I then get the same error as above. If I say no, the rest of the OS installs but when it then does the reboot it fails to load the OS.

Thanks for any help you can provide.

UPDATE When I go into rescue mode and try to install the boot loader I get:

 /dev/cciss/c0d0p3 doesn't have any corresponding BIOS drive
share|improve this question
    
What if you try to run install grub from the command line? –  Jure1873 May 10 '13 at 16:10
    
I just get a read only file system so it can't install the grub boot loader –  Boardy May 24 '13 at 13:57

1 Answer 1

up vote 1 down vote accepted
+50

You could try the procedure to manually reinstall grub from here: http://www.novell.com/support/kb/doc.php?id=7001376

It seems that the kernel and grub can't map the disks on your raid array.

share|improve this answer
    
Thanks this has been bugging me for weeks, everything I tried failed. –  Boardy May 28 '13 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.