Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to run Java 1.7.0_21-b11 with GLIBC 2.3.6. Java 7 requires at least GLIBC 2.4.

I've tried this solution, so using ldd, I've found the following dependencies:

ld-2.7.so
ld-linux.so.2
libc.so.6
libdl.so.2
libpthread.so.0

I've copied these files (along with ld-2.7.so) from similar but newer system (both are Slackware), and tried to invoke java with preloaded libraries, but I got a segfault:

$ LD_PRELOAD="./ld-linux.so.2 ./libc.so.6 ./libd l.so.2 ./libpthread.so.0" ./ld-2.7.so /usr/lib/java_new/bin/java
Segmentation fault

I'm a bit stuck so any advice how to proceed would be appreciated.

share|improve this question

1 Answer 1

I had the same problem - running Java on a build server running on an old Ubuntu.

I've installed all required libraries in a folder and used LD_LIBRARY_PATH to point to them. It did not work. I think that the problem was that glibc is not compatible with the kernel.

The solution was to install a new Linux distribution and migrate the build server to the new Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.