Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After adding this lines to the file squid.conf:

httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy  on
httpd_accel_uses_host_header on

I'm having this error message:

* Restarting Squid HTTP Proxy 3.0 squid3                                       2013/05/12 20:33:57| cache_cf.cc(346) squid.conf:59 unrecognized: 'httpd_accel_with_proxy'
2013/05/12 20:33:57| cache_cf.cc(346) squid.conf:60 unrecognized 'httpd_accel_uses_host_header'
2013/05/12 20:33:57| cache_cf.cc(346) squid.conf:61 unrecognized: 'httpd_accel_host'
2013/05/12 20:33:57| cache_cf.cc(346) squid.conf:62 unrecognized: 'httpd_accel_port'

how can i resolve this problem?

share|improve this question
up vote 2 down vote accepted

There was a change in squid config option after version 2.6, replace that with :

http_port 3128 transparent
http_port 80 vhost
share|improve this answer
    
Thanks for the reply :) – volcano May 13 '13 at 16:04

In squid versions 3.1 and up, the directive is: http_port 80 intercept. In versions 2.6 up to and not including 3.1, it's http_port 80 transparent. The intercept or transparent option tells squid to infer the proxy destination from the Host: header as with httpd_accel_uses_host_header.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.