Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running plesk 11 on Ubuntu. In the Website Scripting area when you edit a website, you can enable python, perl, CGI support and a couple of other options. (snip)

All the sites run on PHP, so I enter want to disable/lock those settings, so staff don't have to worry about them.

Reading the docs I found this http://download1.parallels.net/Plesk/PP10/10.1.1/Doc/en-US/online/plesk-administrator-guide/index.htm?fileName=65888.htm which sounds useful, but it doesn't work! I can configured the file, stopped/started psa and it doesn't seem to read it.

I edited the reseller permissions, and reseller plans to allow them to be overwritten, however that still didn't make a difference when I edited a site, or created a new one.

Any ideas?

share|improve this question

closed as off topic by Michael Hampton, EEAA, Ward, Jenny D, mdpc May 13 '13 at 16:31

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Under which user you have check that site settings is working? Plesk admin is not effected by settings in /usr/local/psa/admin/conf/site_isolation_settings.ini

I have checked in Plesk 11 that unprivileged user can't change hosting settings if they are predefined in /usr/local/psa/admin/conf/site_isolation_settings.ini:

[hosting]
;php = any
php_handler_type = fastcgi
python = off
perl = off
fastcgi = off
miva = off
ssi = off
cgi = off
;ssl = on
shell = /usr/local/psa/bin/chrootsh
asp = off
php_safe_mode = off
coldfusion = off

Here the screenshot of subscription level user's session, user has role "Administrator":

enter image description here

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.