Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Between 2 dedicated servers, hosted in 2 different DCs (different companies), the FTP upload speeds are always much slower than the max connection speed. Specs: Windows 2008 on both. Quad core/8 GB RAM/1 Gbit network care FileZilla FTP Server

  • Both have 100mbps connections
  • Speed maxes out at about 30 mbps
  • Ping shows 30 ms of latency
  • Tried multiple transfer threads- it helped increase speeds a little but never past 30 mbps.
  • Tested an HTTP transfer on the client server from the same host server while FTP was running- it transferred at 12 mbps! (1.5 MBytes/S).. and did not affect FTP speeds- FTP speeds stayed constant. That is, total server speed was 42 mbps while transferring over HTTP and FTP. So it seems the connection between the 2 isn't being fully used.
  • For the client server, I tried connecting to different FTP servers and seeing if I got different transfers. It was always slow with FTP- around 400 kBytes/s with 3 streams.
  • For the host server, I tried other FTP connections and they were better but still not as great as the HTTP transfer.

Side note- I've noticed this "slower FTP than HTTP effect" a lot after speaking to some users across all 3 data centers I've ever used- Users say FTP speeds are never as fast as HTTP download. But sometimes I think it's something about my configuration.

Here are some possibilities, but maybe it's something else: 1. Is it possible that there is traffic shaping going on? I read this: http://oreilly.com/catalog/bgp/chapter/ch06.html It seems to suggest that protocols like HTTP are going to get priority and FTP, which is latency-friendly, is going to get the back seat. But I'm using DCs- not personal Internet connections.

  1. Is there something I can do with my TCP window size? I tried adjusting it on FileZilla Server to make it larger or smaller... I tried every value and it never let me break the 30mbps barrier.

Let me know your thoughts. Here is a tracert, with some names hidden. Tracing route to ******** over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms **********

2 <1 ms <1 ms <1 ms **********

3 6 ms 6 ms 6 ms **********

4 7 ms 6 ms 6 ms 66.208.216.85

5 11 ms 11 ms 7 ms be-12-cr01.350ecermak.il.ibone.comcast.net [68.86.84.189]

6 8 ms 7 ms 7 ms pos-1-6-0-0-pe01.350ecermak.il.ibone.comcast.net [68.86.87.130]

7 6 ms 6 ms 7 ms te0-3-0-17.ccr21.ord03.atlas.cogentco.com [154.54.11.253]

8 7 ms 7 ms 7 ms be2006.mpd21.ord01.atlas.cogentco.com [154.54.5.17]

9 32 ms 32 ms * *****.atlas.cogentco.com

10 42 ms 100 ms 33 ms *****.atlas.cogentco.com

11 32 ms 32 ms 31 ms **********

12 32 ms 32 ms 31 ms [*DESTINATION****]

Trace complete.

share|improve this question
    
How are the two servers connected? Over the internet? Or via a private link between the two datacentres? –  Nexus May 13 '13 at 5:34
    
Over the Internet. No private link. –  user1086584 May 14 '13 at 7:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.