Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Solved!!

So here is the answer - I had sites.pp not site.pp Thanks @Shane Madden

debug: importing '/etc/puppet/manifests/nodes.pp' in environment production

If you are including nodes.pp in your site.pp should show up in --debug logging.

I am having a problem diagnosing a base puppet master / client issue. The puppet master is running as another server name and is set correctly in /etc/puppet/puppet.conf file. Both file and service command are not functioning on the client. No errors any where in debug mode.

Here is a breakdown:

  1. Client and master are talking correctly. I run both in --no-daemonize --debug and they are chatting nicely - no errors or warnings.
  2. If I do a puppet apply site.pp on the client side it work. I am removing the node parens.
  3. The puppet file on the server parses correctly.
  4. I worked around the "Could not retrieve fact fqdn" error by setting the hostname in the /etc/hosts file.

It appears that the client is not picking up the site.pp node name, and I have used default. Or for some reason the puppet command is not running.

I have tried doing a simple file sync and a service command, and both are not running correct.

The debug output on the master show's it received the report from the client.

How do I get more debugging information beside --debug.

Thanks for the help in advance!

share|improve this question
    
Where's the site.pp located, and is your master throwing any errors about being unable to load it? Does your client system have anything in its cached catalog at /var/lib/puppet/client_data/catalog? –  Shane Madden May 13 '13 at 19:24
    
no errors that I can see. Ah typo I had a typo ... sites.pp not site.pp ... please answer the question :) –  chrislovecnm May 13 '13 at 20:32
    
wow ... typos are my bane :D –  chrislovecnm May 13 '13 at 20:34
add comment

1 Answer 1

up vote 1 down vote accepted

When the client isn't loading the catalog as expected, a few things to check:

  • Make sure the catalog the client is getting makes sense - it should be in $vardir/client_data/catalog.
  • Make sure during the run the client isn't using the cached catalog for some reason - usually this is when the master has an error or is not accessible.
  • Verify which environment your node is using, if you have multiple.
  • If changes to the files aren't being picked up, make sure they're being read properly - adding an err('this ran') will log the message on the master during catalog generation.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.