Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The link below contains an image that is how I wish my build architecture:

http://i.imgur.com/qg7LM5j.png

I can configure this, without SSL at any point, and works fine. But when I configure a SSL connection between the client and the proxy, it doesn't work.

Here is my actual configuration:

LoadModule weblogic_module modules/mod_wl_22.so

<Location />
    SetHandler weblogic-handler
    PathTrim /
</Location>
<IfModule mod_weblogic.c>
    WebLogicHost xxx.xxx.xxx.xx
    WebLogicPort xxxx

    WLProxySSL ON
    SecureProxy OFF

    Debug ON

    WLLogFile "C:\temp\wlproxy.log"
    WLTempDir "C:\temp"
</IfModule>

Everything else remains the same as setting the standard. I need this configuration because I have to sniff the packets after them leaves the proxy.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Turning on WLProxySSL will enable HTTPS communication between Apache and Weblogic which is labelled as HTTP in your diagram. If your diagram is correct and you don't want SSL between Apache and Weblogic, you should remove that line.

To force SSL between a client and Apache, you will need to either stop Apache from listening on port 80, or redirect traffic on port 80 to port 443. One way to do that would be to use Redirect permanent inside a virtual host

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.