Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm in the process of upgrading from Squeeze to Wheezy but I've hit a dependency problem I'm not sure how to reolve...

So far I've done:

dpkg --audit
dpkg --get-selections | grep hold

aptitude 

"No packages are scheduled to be installed, removed or upgraded"

vi /etc/apt/sources.list

aptitude update 

(and resolved all the package configuration changes)

However when I try

aptitude dist-upgrade

I get the following which I don't know how to resolve

The following packages have unmet dependencies:
  libkrb5-3: Conflicts: libkrb53 but 1.8.3+dfsg-4squeeze6 is installed.
  libapache2-modsecurity: Conflicts: mod-security-common (< 2.5.13-1) but 2.5.12-1+squeeze2 is installed.
  libk5crypto3: Conflicts: libkrb53 but 1.8.3+dfsg-4squeeze6 is installed.
  libstdc++6: Breaks: gcc-4.1 but 4.1.2-29 is installed.
          Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is installed.
  libdigest-sha1-perl: Depends: perlapi-5.10.1 which is a virtual package.
  perl: Breaks: libcompress-zlib-perl (< 2.033) but 2.024-1 is installed.
        Breaks: libio-compress-base-perl (< 2.033) but 2.024-1 is installed.
        Breaks: libio-compress-zlib-perl (< 2.033) but 2.024-1 is installed.
  perl-base: Conflicts: defoma (< 0.11.12) but 0.11.11 is installed.
  libgomp1: Breaks: gcc-4.1 but 4.1.2-29 is installed.
        Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is installed.
  perl-modules: Conflicts: defoma (< 0.11.12) but 0.11.11 is installed.
  libmp3splt0-mp3: Conflicts: libmp3splt-mp3 but 0.5.6-1 is installed.
  libmp3splt0-ogg: Conflicts: libmp3splt-ogg but 0.5.6-1 is installed.
  libgcc1: Breaks: gcc-4.1 but 4.1.2-29 is installed.
       Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is installed.
  libept1: Depends: libapt-pkg4.10 which is a virtual package.
  libkrb5support0: Conflicts: libkrb53 but 1.8.3+dfsg-4squeeze6 is installed.
  php5-suhosin: Depends: phpapi-20090626 which is a virtual package.
  libgfortran3: Breaks: gcc-4.1 but 4.1.2-29 is installed.
            Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is installed.
  libmp3splt-mp3: Depends: libmp3splt0 (= 0.5.6-1) but 0.7.2-2 is to be installed.
  libmp3splt-ogg: Depends: libmp3splt0 (= 0.5.6-1) but 0.7.2-2 is to be installed.
  percona-server-common-5.5: Conflicts: mysql-common but 5.5.31+dfsg-0+wheezy1 is to be installed.
  php5-common: Breaks: php5-suhosin but 0.9.32.1-1 is installed.
The following actions will resolve these dependencies:

Remove the following packages:
1)      defoma
2)      gcc-4.1
3)      gcc-4.3
4)      libapache-mod-security
5)      libcompress-zlib-perl
6)      libdigest-sha1-perl
7)      libept1
8)      libio-compress-base-perl
9)      libio-compress-zlib-perl
10)     libkrb53
11)     libmp3splt-mp3
12)     libmp3splt-ogg
13)     libpango1.0-common
14)     percona-server-client-5.5
15)     percona-server-common-5.5
16)     percona-server-server-5.5
17)     percona-xtrabackup
18)     php5-suhosin
19)     psfontmgr
20)     x-ttcidfont-conf
21)     xtrabackup

  Keep the following packages at their current version:
22)     libapache2-modsecurity [Not Installed]
23)     modsecurity-crs [Not Installed]

  Leave the following dependencies unresolved:
24)     mysqltuner recommends mysql-server
25)     phpmyadmin recommends mysql-client

Accept this solution? [Y/n/q/?]
share|improve this question
    
Does apt-get dist-upgrade do better than aptitude? –  DerfK May 13 '13 at 22:55
    
Did you install any packages from any unofficial sources? Do you have any unofficial repositories enabled? It seems pretty obvious you do, because percona isn't in squeeze. If you are going to use unofficial stuff, then you have to accept that upgrades probably will break until you remove all the unofficial stuff. –  Zoredache May 13 '13 at 22:56
    
Try uninstall package, upgrade and then install them again –  Brigo May 13 '13 at 23:07
    
I completed the upgrade by uninstalling then reinstalling Percona. There were a few dependency issues with other packages but nothing serious. However I've now hit the problem of php 5.4 not being supported by several of the application I run and I'm trying to downgrade php using serverfault.com/questions/367885/…. However the only version on offer when I do 'apt-cache showpkg php5' is 5.4.4-14... –  Fat Finger May 14 '13 at 23:07
    
By the way: debian.org/releases/wheezy/amd64/release-notes/… "4.4. Upgrading packages The recommended way to upgrade from previous Debian releases is to use the package management tool apt-get. In previous releases, aptitude was recommended for this purpose, but recent versions of apt-get provide equivalent functionality and also have shown to more consistently give the desired upgrade results." –  aseq May 15 '13 at 1:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.