Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up a Squid caching proxy server at work to cache some map data for one of our web apps. My wpad.dat works great in Firefox & Chrome but it does not work correctly with Internet Explorer. Does anyone know how to get IE to properly use a wpad.dat file? My current file is below, I have had it working when I run all data for the site through the proxy, but that is not what I want to do. Could it partially be due to the fact that the web app is a Silverlight app?

function FindProxyForURL(url, host) 
{
    if (shExpMatch(url, "*/ArcGIS/rest/services/*/tile/*") && isInNet(myIpAddress(), "192.168.0.0", "255.255.0.0"))
    {
        return "PROXY 192.168.11.15:3128; DIRECT";
    }
    else
    {
        return "DIRECT";
    }
}
share|improve this question
    
Are you saying that IE isn't using the wpad.dat file at all or are you saying it isn't behaving correctly? –  RobM May 14 '13 at 14:38
    
Is "Automatically Detect settings" ticked in Internet Options->Local Area Network Settings? Do you know if the clients are pulling the wpad.dat file?? –  Chris S May 14 '13 at 14:46
    
I have the "Automatic configuration script" setting enabled and set correctly and have verified that my machine is pulling down the wpad.dat file using Wireshark. However if the first condition in the wpad.dat file is not met then it doesn't bother checking for anything else it needs to for the site. –  smccloud May 14 '13 at 20:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.