Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PPTP server running and I can connect to it from linux. When I try from windows 7 (2 instances tested) it fails. Here's the syslog for such a conn:

pptpd[540]: CTRL: Client 109.xxx.158.201 control connection started
pptpd[540]: CTRL: Starting call (launching pppd, opening GRE)
pppd[541]: Plugin radius.so loaded.
pppd[541]: RADIUS plugin initialized.
pppd[541]: Plugin radattr.so loaded.
pppd[541]: RADATTR plugin initialized.
pppd[541]: pppd 2.4.5 started by root, uid 0
pppd[541]: Using interface ppp0
pppd[541]: Connect: ppp0 <--> /dev/pts/1
pptpd[540]: GRE: Bad checksum from pppd.
pppd[541]: LCP: timeout sending Config-Requests
pppd[541]: Connection terminated.
pppd[541]: Modem hangup
pppd[541]: Exit.
pptpd[540]: GRE: read(fd=6,buffer=6075a0,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
pptpd[540]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
pptpd[540]: CTRL: Reaping child PPP[541]
pptpd[540]: CTRL: Client 109.xxx.158.201 control connection finished

I played with the mtu and ranged it from 900 to 1500 with no success. My pptp options:

name pptpd
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
proxyarp
nodefaultroute
lock
nobsdcomp
ms-dns 10.10.0.1
noipx
mtu 1404
mru 1404

Remember! Linux client connects so ports and protocols should be enabled.

tcpdump -i eth0 port 1723 or proto 47 shows the following gist: https://gist.github.com/ciokan/5595640 where 109.xxx.158.201 is me, the client.

No firewalls on client. Everything disabled. Im not a network admin and I can't understand jack from that tcpdump. HALP :)

share|improve this question
    
Can you check if those Win7 desktops internal firewall rules prevent inbound ip 47 access for GRE? try again please to see if client fw are off, as it seems like very problem. –  Danila Ladner May 17 '13 at 0:50
    
Firewall off. not working ty –  Romeo Mihalcea May 17 '13 at 1:11
    
Can you try to add "mppe-stateful" into your pptp options? –  Danila Ladner May 17 '13 at 1:15
    
Yes ty, same story unfortunately: GRE: read(fd=7,buffer=60f600,len=8260) from network failed: status = -1 error = Protocol not available –  Romeo Mihalcea May 17 '13 at 1:20
    
Well different error. –  Danila Ladner May 17 '13 at 1:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.