Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu 11.10 on a VPS and have problems running screen for non root users.

Screen is working fine with root though. When I run it as root and hit "tty" I receive the following output:

root@server:/dev# tty
/dev/ttyp3

I read through some other topics regarding this issues and checked the following permissions:

root@server:~# ls -l /usr/lib/pt_chown
-rwsr-xr-x 1 root root 10592 Sep 21  2012 /usr/lib/pt_chown
root@server:~# ls -l /usr/bin/screen
-rwxr-sr-x 1 root utmp 375984 Jun  6  2011 /usr/bin/screen

The error message screen is stating involved the message: could not find a pty

So I ran the command:

root@ghost:/dev# sudo MAKEDEV ptyp ptyq

Now screen is starting up for the none root user but brings this error:

Cannot open /dev/ttyp4: Permission denied

Can someone bring some light into my darkness?

share|improve this question
    
What is the output of ls -l /dev/ | grep tty? Sounds like the non-root user just doesn't have permission. –  Nathan C May 17 '13 at 18:27
    
It says: crw-rw-rw- 1 root tty 3, 5 May 17 20:09 ttyp5 crw-rw-rw- 1 root tty 3, 6 May 17 20:09 ttyp6 crw-rw-rw- 1 root tty 3, 7 May 17 20:09 ttyp7 And screen gives my none root: Cannot open /dev/ttyp5: Permission denied –  Bass May 17 '13 at 19:37
    
Hm. Try usermod -a -G tty nonrootuser –  Nathan C May 17 '13 at 19:39
    
Mh, did not work. Same issue :( –  Bass May 17 '13 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.