Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm tuning my server for low-latency The guide suggests to disable this option "Processor Power and Utilization Monitoring" because:


Disables iLO Processor State Mode Switching and Insight Power Manager Processor Utilization Monitoring, and its associated SMI

Disabling System Management Interrupts to the processor provides one of the greatest benefits to low-latency environments. Disabling the Processor Power and Utilization Monitoring SMI has the greatest effect because it generates a processor interrupt eight times a second in G6, G7, and Gen8 servers.


But I can not find this option in BIOS. I've checked HP ROM-Based Setup Utility User Guide and it is not there.

How to disable "Processor Power and Utilization Monitoring", what exact steps should I do?

share|improve this question
    
I feel like I answer the same questions for you often. You haven't gotten this trading system running yet? –  ewwhite May 18 '13 at 11:05

1 Answer 1

up vote 9 down vote accepted

This is outlined in the document you linked under the "Tuning Procedures" heading.

In order to enter the Advanced system options menu for modifying a G6 or newer HP ProLiant for a low-latency application, you need to get to the main BIOS screen by pressing F9 during POST.

enter image description here

Once there, type Ctrl-A. This will present an additional menu named "Service Options" at the bottom of the list.

enter image description here

Select "Service Options" and you'll see the advanced system options, including the optimization you're looking to make. Change "Processor Power and Utilization Monitoring" to "Disabled". Escape and follow the prompts to save your changes.

enter image description here

One note. In realtime applications, there are a good number of things than can be tuned before resorting to this, but the setting is safe.

enter image description here

share|improve this answer
    
thanks for detailed response, will try today! –  javapowered May 20 '13 at 13:14
    
this works fine, thank you once again! –  javapowered May 20 '13 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.