Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When upgrading debian squeeze to wheezy, the upgrade of mysql to mysql-server-5.5 fails:

# apt-get dist-upgrade -u
...
Setting up mysql-server-5.5 (5.5.31+dfsg-0+wheezy1) ...
[ ok ] Stopping MySQL database server: mysqld.
...
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.

dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

When I run /usr/bin/mysqld_safe --skip-syslog, the resulting log file has this message repeated:

130520 23:54:23  InnoDB: Error: trying to access tablespace 1 page no. 2,
InnoDB: but the tablespace does not exist or is just being dropped.

As far as I know, I don't have any InnoDB tables.

What do? I don't want to --purge mysql unless it's absolutely necessary.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

It appears as if there were innoDB-related files (ibdata1, ib_logfile, etc) in my /var/lib/mysql/ directory. Per the suggestions in this mailing list post, I ran rm ib* and re-ran apt-get dist-upgrade. Everything appears to work.

share|improve this answer

I had debian backports in my /etc/apt/sources.list, and I just blindly replaced words squeeze with wheezy without checking what repos I'm using. When I did dist-upgrade, I ended up with similar results that you are seeing.

Remove backports repos, if you have any, and do an update/upgrade.

share|improve this answer

I ran into the same problem. The issue was with the source list of debian wheezy. The following steps solved my problem for mysql-server in debian wheezy.

  1. Go to http://debgen.simplylinux.ch/ to generate the source list.

2.Generate the source list.

  1. Copy and paste the generated list into your /etc/apt/sources.list file. (Make a backup first!)

4.After that, run #apt-get update

Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.