Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've followed the guide here (https://www.windowsazure.com/en-us/develop/net/common-tasks/custom-dns-web-site/?fb=en-US).

It states how to set up a domain.

Now, my web-app works when going to http://fablelane.com. This app makes a redirect to http://www.fablelane.com, which then returns a 404 (the redirect is normal, and is part of my URL rewriting rules, proving that the http://fablelane.com URL works).

If I go to http://fablelane.azurewebsites.net/, the entire website loads without issues. But here, it doesn't make the redirect either.

Whenever I try to add the domain in Azure, I get the exclamation mark indicating that something is wrong.

enter image description here

If I hover over the exclamation mark, the following error is displayed.

The DNS record for 'www.fablelane.com' that points to 'fablelane.azurewebsites.net' could not be located. If you want to configure an A record, you must first create a CNAME record with your DNS provider for 'awverify.www.fablelane.com' that points to 'awverify.fablelane.azurewebsites.net'. First allow the resource record to propagate, and then create the A record.

Finally, here are my DNS settings from my control panel.

enter image description here

I have waited more than 24 hours for the DNS to propagate, and still my site returns a 404. The instance is a dedicated instance.

Edit

I have now removed the URL rewriting rule, so that you can go to http://fablelane.com directly, which works. http://www.fablelane.com still doesn't work though, which is my main problem.

share|improve this question

closed as too localized by Ward, pauska, gWaldo, growse, mgorven May 22 '13 at 22:14

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
DNS doesn't propagate. Neither its documentation does. –  poige May 22 '13 at 5:41

1 Answer 1

up vote 0 down vote accepted

I figured it out! After 30 hours of hard working, I tried removing the *.fablelane.com A-record, and the www.fablelane.com A-record. I had suspected that the order of the DNS records might have influenced the result.

Now it works.

share|improve this answer
    
That's not how DNS works, but there no such thing as A-record propagation either... –  Chris S May 22 '13 at 5:14
    
Thanks. Very informative! –  Mathias Lykkegaard Lorenzen May 22 '13 at 5:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.