Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to edit text files on logging-in windows telnet service with terminal emulator like putty

notepad? of course not. I tried vim for win32 console but it is worthless. edlin? oh no. please let me know something.

please some more hints.

on my windows 2003, I cann't find 'edit'

C:\Documents and Settings\crowdy>edit
'edit' is not recognized as an internal or external command,
operable program or batch file.

these are what I have on server. I fotgot to mention that it's windows 2003 server japanese. sorry.

C:\WINDOWS\system32>dir e*.exe e*.com /w
 ドライブ C のボリューム ラベルは program です
 ボリューム シリアル番号は 0C71-A795 です

 C:\WINDOWS\system32 のディレクトリ


 C:\WINDOWS\system32 のディレクトリ

edlin.exe           esentutl.exe        eudcedit.exe        eventcreate.exe     eventtriggers.exe
eventvwr.exe        exe2bin.exe         expand.exe          extrac32.exe
               9 個のファイル             556,682 バイト
               0 個のディレクトリ   3,358,867,456 バイトの空き領域
share|improve this question
    
@mrdenny/ that sounds reasonable. then, is there any alternative to 'edit'? –  crowdy Aug 7 '09 at 1:59
    
I've found that there's no 'edit' command in windows XP professional JAPANESE either! –  crowdy Aug 7 '09 at 2:45
1  
I got edit*.* and qbasic*.* from windows XP pro KOREAN and copied it to some directory on my local japanese machine(not server)to test. 'edit' or 'qbasic' doesn't work until I do 'chcp 437'. for terminal emulator, it doesnt work despite of 'chcp 437'..... god. –  crowdy Aug 7 '09 at 4:03
    
when I execute the copied 'edit' remotely, it looks like instance is created, but I cann't see any drawing of 'edit' screen. after that, it echoes characters as I type something. <Alt-F,X>? that keys are sended to my emulator. I can not exit that status after all. I had to close my session. –  crowdy Aug 7 '09 at 4:11
    
@mh/ I've checked all windows 2003 JAPANESE editions our company has have no C:\Windows\System32\edit.com (however KOREAN edition has it). I believe yours are not JAPANESE edition. –  crowdy Aug 7 '09 at 18:38
show 1 more comment

3 Answers

Edit is a bit slow under NT (it's a .com rather than a .exe), but it's good enough if you can't use anything else.

If you can't find it, access it thusly:

C:\Windows\System32\edit.com myfile.txt
share|improve this answer
    
oh no. I haven't. double checked. why don't I have it?? should it be on windows 2003 server?? –  crowdy Aug 6 '09 at 15:55
    
I haven't had a machine in the last decade that I've tried it on that didn't have it. From any command prompt I can just type edit and it opens –  sparks Aug 6 '09 at 20:28
    
From your telnet session: C: CD \windows CD \system32 dir edit.* –  Jimmy Shelter Aug 6 '09 at 21:22
    
hmm, what happened to my server. oh, the server is "windows 2003 standard japanese". I can not find 'edit*.*' even under I386 folder –  crowdy Aug 7 '09 at 0:19
    
It should be in there somewhere. I've got Windows 7 and it's still sitting in the Windows\System32 folder. I wonder if it's not included on other languages as it doesn't support uni-code text? –  mrdenny Aug 7 '09 at 0:59
show 1 more comment

Edit. Actually not too bad of a text editor.

share|improve this answer
add comment

nano is pretty simple and a Win32 binary is available. It's compiled against Cygwin, but the necessary DLLs are included in the ZIP file. The simplest installation is to just dump nano.exe and the DLLs into the same directory, then just run nano.exe.

If you need a CLI program to unzip it, you can use the one from Info-Zip. A self-extracting version is available here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.