Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Problem is this: I can send E-Mails from my E-Mail (evolutio@lars-dev.de) to my other Emails like @gmail @web @gmx ...

But when I try to send a E-Mail from GMail to evolutio@lars-dev.de I have the Error:

Delivery to the following recipient failed permanently:
     evolutio@lars-dev.de

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain lars-dev.de by mx1.cw4.me. [195.138.240.200].

The error that the other server returned was:
554 5.7.1 <evolutio@lars-dev.de>: Relay access denied

My main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_tls_auth_only = yes
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
.tls_random_source = dev:/dev/urandom

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = lars-dev.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydomain = lars-dev.de
myorigin = $mydomain
mydestination = $mydomain, localhost.$mydomain,  localhost.localdomain, localhost
#mydestination = $myhostname, localhost.$mydomain, $mydomain
relayhost = smtp.lars-dev.de
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

# Virtual mailbox settings
virtual_mailbox_domains = proxy:mysql:$config_directory/mysql_virtual_domains_maps.cf
virtual_mailbox_base = /var/vmail
#virtual_mailbox_base = /var/spool/mail
virtual_mailbox_maps =
    proxy:mysql:$config_directory/mysql_virtual_mailbox_maps.cf,
    proxy:mysql:$config_directory/mysql_virtual_alias_domain_mailbox_maps.cf,
    proxy:mysql:$config_directory/mysql_virtual_alias_domain_catchall_maps.cf
virtual_alias_maps =
    proxy:mysql:$config_directory/mysql_virtual_alias_maps.cf,
    proxy:mysql:$config_directory/mysql_virtual_alias_domain_maps.cf
virtual_mailbox_limit = proxy:mysql:$config_directory/mysql_virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = Sorry, the user's maildir has overdrawn his diskspace quota, please try again later.
virtual_overquota_bounce = yes
virtual_minimum_uid = 150
virtual_uid_maps = static:150
virtual_gid_maps = static:8
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

# SASL Authentication
smtpd_sasl_auth_enable = yes
smtpd_sasl_exceptions_networks = $mynetworks
#smtpd_sasl_local_domain = $myhostname
smtpd_sasl_local_domain = lars-dev.de
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

# No open relay!
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_hostname
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
#    permit

master.cf

#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
submission inet n       -       -       -       -       smtpd
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
smtps     inet  n       -       -       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
#628       inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o smtp_fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
retry     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
#   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
#  mailbox_transport = lmtp:inet:localhost
#  virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus     unix  -       n       n       -       -       pipe
#  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
# Old example of delivery via Cyrus.
#
#old-cyrus unix  -       n       n       -       -       pipe
#  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}

dovecot   unix  -       n       n       -       -       pipe flags=DRhu
  user=vmail:mail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${recipient}

#dovecot   unix  -       n       n       -       -       pipe flags=DRhu
#  user=vmail:mail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${recipient}
share|improve this question
    
You are relaying your mail to smtp.lars-dev.de, how is the config of smtp.lars-dev.de –  kockiren May 22 '13 at 7:28
    
The relayhost is nothing I have read that I should change the relayhost to smtp.lars-dev.de but it didn't worked. I set the relayhost to nothing –  Evolutio May 22 '13 at 7:30
    
Can you post your /var/log/syslog related to the sent mail. –  kockiren May 22 '13 at 7:31
    
When I check the NS for MX records I get the Host mx0.cw4.me. are you sure that this is your postfix server? So this server is not able to relay to another domain. You must set your NS to your own postfix server. –  kockiren May 22 '13 at 7:33
    
This is what I have found: pastebin.com/4wJPjhdY –  Evolutio May 22 '13 at 7:34

1 Answer 1

up vote 1 down vote accepted

The MX records of your Domain not set to your postfix server, you need to set your MX records to the right smtp Server. In your case the Server mx0.cw4.me. is set as MX and this server don't accept mails for lars-dev.de.

$ host lars-dev.de
lars-dev.de has address 195.138.240.218
lars-dev.de mail is handled by 0 mx0.cw4.me.
lars-dev.de mail is handled by 0 mx1.cw4.me.

Maybe this is the MX of your Hoster and this Server don't accept Mails for lars-dev.de

$ telnet mx0.cw4.me smtp
Trying 195.138.240.200...
Connected to mx0.cw4.me.
Escape character is '^]'.
220 mx0.cw4.me ESMTP Postfix (contentWays Infrastructure - www.contentways.de)
ehlo rene
250-mx0.cw4.me
250-PIPELINING
250-SIZE 512000000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
mail from:test@test.com
250 2.1.0 Ok
rcpt to:evolutio@lars-dev.de
554 5.7.1 <evolutio@lars-dev.de>: Relay access denied

In the above Telnet session you can see that your hosters server don't accept mails for lars-dev.de

share|improve this answer
    
Okay thx. I contact my hoster to solve the problem. –  Evolutio May 22 '13 at 7:44
    
Hey, the mx record is set to my server I think. The problem with "relay access denied" is solved, but I aren't getting any E-Mail in my Inbox. This is in the mail.log pastebin.com/pfisHdSK but under /var/mail/* or /var/spool/mail/* I cant find any Email :( Where is the Problem? –  Evolutio May 23 '13 at 6:19
    
Please open a new Question for this issue. Its a issue for dovecot and local delivery. You get your mail deliverd but you cant see this mail in your inbox. Post this as new Question with logs and config from dovecot. –  kockiren May 23 '13 at 6:44
    
The NS records are'nt set correct. Youre provider must set a 10 MX record but they set a 0 MX –  kockiren May 23 '13 at 7:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.