Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm following the instructions at http://www.ntop.org/download.html.

At some point during the ./configure phase of the install, I get this error message:

configure: error: Unable to find RRD at /usr/local/rrdtool: please use --with-rrd-home=DIR

I run which rrdtool and I get:

/usr/local/bin/rrdtool

...so I run: ./configure --with-rrd-home=/usr/local/bin/rrdtool

The installation continues, until it fails at the same spot, same error. I've tried a bunch of varying paths, like:

`./configure --with-rrd-home=/usr/local/bin/`
`./configure --with-rrd-home=/usr/local/bin`
`[...]`
`./configure --with-rrd-home=/usr`

... as I read in a suggestion while Googling the problem.

If it matters, I don't have root access on this machine. It's a dedicated server at my web host.

Any suggestions?

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

Even better than all of the previous answers, why are you trying to install this by hand?

The ports tree contains ntop:

http://www.freshports.org/net/ntop/

So if you have the ports tree installed (if not, check the FreeBSD Handbook on using ports)

The ports tree is an amazing feature for FreeBSD in that it does the dependency tracking and compiles said dependencies for you. The version in the ports tree is outdated by 2 versions from what I can see, generally a nice email to the port maintainer can help you solve that issue!

Edit: Re-read your question and it seems that you are not running as root, how are you planning on getting access to a bpf device to log packets?

share|improve this answer
1  
Thank you for saying that. ;-) Why use FreeBSD at all when you do not take advantage of ports. –  Till May 30 '09 at 23:50
    
+1, he'll need root access to install from the Ports tree, and the easiest/quickest way would be pkg_add -r ntop –  Chris S Aug 25 '10 at 19:57
add comment

Have you tried just "./configure --with-rrd-home=/usr/local"?

share|improve this answer
    
It should be "./configure --with-rrd-home=/usr/local/bin". –  user1797 May 6 '09 at 1:34
    
No, I'm actually suggesting he leave off the /bin suffix - usually the home of an app is the base directory (like /usr or /usr/local). –  Luke May 6 '09 at 2:40
add comment

Have you tried to symlink (without root or sudo access you might not be able to do this neither)? On your shell:

ln -s /usr/local/bin/rrdtool /usr/local/rrdtool

One thing though, if you do not have root on the box, your usage of ntop will be limited. The errors you see might be caused by that fact.

share|improve this answer
    
"I don't have root access on this machine" - Can't write to /usr/local without root access (by default). –  Chris S Aug 25 '10 at 19:56
add comment

if you don't change rrdtool default installation address, you should use --with-rrd-home=/opt/rrdtool-V which V is your rrdtool verion number.

share|improve this answer
    
There's no /opt folder in FreeBSD; and the default location would be /usr/local/bin –  Chris S Aug 25 '10 at 19:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.