Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As a followup to this question, I have discovered that this closed source programme is 32bit and I have an amd64 server. The server is gentoo that has recently been upgraded.

What do I need to install in order to make this programme work? I know it's possible because I have another gentoo amd64 server that can run this programme.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

On Gentoo there is a series of packages which contain 32-bit binaries of all the common system libraries for precisely this purpose. Do a search for emul-linux using equery and you'll get the list. Usually you need at least app-emulation/emul-linux-x86-baselibs and app-emulation/emul-linux-x86-compat but there are a few others which pertain to X11 apps.

The other options are running a multilib environment or setting up an 32-bit chroot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.