Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

About a month ago I added Exchange 2013 to my org and migrated my box to it (from Exchange 2010). At that point my rules completely stopped working automatically. If I ran them manually they worked fine.

Another user's mailbox I migrated works fine. However, this box didn't have any rules until after the migration and me discovering that my own rules no longer worked.

I have tried:

  • deleting and recreating the rules from Outlook 2013;
  • deleting and recreating the rules from OWA;
  • starting Outlook with /cleanrules and recreating them;
  • deleting/disabling and creating/enabling rules from Exchange Management Shell;
  • turning off and on Cached Exchange Mode in Outlook.

Nothing has worked and I'm not even sure what to try next.

edit: By the way, these are basic rules like moving emails upon arrival to different folders based on keywords in the subject and/or the sender.

edit2: Why is this being voted for closure?

share|improve this question
1  
Regarding the close votes: I suspect it's because people have a knee-jerk reaction concerning questions that prominently feature Outlook. "User issue, RAWR!" –  Wesley May 23 '13 at 19:06
    
I was afraid of that but I tried at superuser first and got nothing. It seems to me that this is a problem in my mailbox or with the Exchange database; something deeper than Outlook anyway. –  idon'twearsuits May 23 '13 at 19:55

3 Answers 3

You likely have hidden (broken) rules in the mailbox. Try using MFCMAPI to clear them out.

Launch MFCMAPI, and select Session -> Logon. Browse to Top of Information Store -> Inbox and right-click and select 'Open Associated Content Table'. You're looking for messages with the message class IPM.Rule.Message. Remove those using the DELETE_HARD_DELETE delete option.

(Note that doing this will remove all of your rules. You may want to just go looking for one that looks out-of-place or broken.)

share|improve this answer
    
It didn't work. I've been working with Microsoft on this issue and have used this tool at their direction though they haven't specifically asked me to do this. They collected a lots of diagnostic info and logs but still don't know what the problem is exactly. –  idon'twearsuits Jul 3 '13 at 18:36

For Exchange environment:

  1. On the root of your mailbox, right click any black place, select Properties > button Advanced
  2. Go to the Advanced tab , and disable “Cached Exchange Mode”.
  3. Press Win + R keys, type outlook.exe /cleanrules, and press Enter.
  4. restart outlook

Once you have done any of the above methods, re-create the rule to check if it is working.

share|improve this answer
up vote 0 down vote accepted

Apologies for forgetting about this post but I did find a solution in October of 2013.

For some reason my mailbox had been set as the Journal Report NDR destination and, beginning with Exchange 2013, mailbox and transport rules do not get processed for the mailbox with this assignment.

This can be fixed with Exchange Management Shell and the following commands (first to verify, then to reassign):

PS> Get-TransportConfig | Select JournalingReportNdrTo
PS> Set-TransportConfig -JournalingReportNdrTo <new_email_address>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.