Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having some issue deploying a VM from template with guest customization. I have not been able to find any answers on the web. Here is my setup:

vSphere 5.1.0 Build 1064983

  1. Create a VM (WIN2K8R2) based on Windows Server 2008 R2 with Administrator password as P@ssw0rd
  2. Install VMware Tools
  3. Activate Windows
  4. Shutdown VM (WIN2K8R2)
  5. Clone VM (WIN2K8R2) to a template (WIN2K8R2T1)
  6. Deploy a VM (WIN2K8R2T1S1) from template (WIN2K8R2T1) with Guest Customization Spec
  7. VM (WIN2K8R2T1S1) successfully created from template (WIN2K8R2T1)

  • Issue is, if i don't set "Automatically Logon as Administrator" in the Guest Customization Spec, i cannot logon to windows.
  • If I set "Automatically Logon as Administrator", the VM automatically logon, but if i log-off, i cannot logon
  • If I set "Automatically Logon as Administrator", the VM somehow removes the "Administrator" password. And if I go to "Edit Local Users", i get option "Set New Password" for the Administrator user. Once I set a new password, then i can use the new password to logon.
  • I also see that the Windows is no longer activated.
  • If i specify domain credentials in the customization spec for the VM to be joined to a domain, it does not join it.
  • it looks like the guest customization is not really working?

Any idea what is going on here? I have been able to reproduce this with Windows Server 2008 R2 and Windows Server 2012.

share|improve this question

Found this to be a bug when using the vSphere Web Client. When using the vSphere Client for Windows, customization works fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.