Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm a total newbie to this and hope you might be able to help me.

I just put my website up on a VPS server last week. I've been trying to get familiar with Terminal in Ubuntu and ssh for accessing the site, rather than shelling out more for cPanel etc.

While browsing around my VPS settings yesterday I went into something called Virtual Machine Console.

A black command line looking screen opened up with:

CentOS release 6.2 (Final) kernel 2.6.32-220 etc...

There were buttons at the top - 'Disconnect', 'Options', 'ClipBoard', 'Send Ctrl Alt Delete', 'Refresh'

Stupidly, I clicked the 'Send Ctrl Alt Delete', all this text started coming up on the screen 'Kill, Kill etc' and now my website is gone.

Later on in Terminal I ssh'd into the server and I can see all the files seem to be still there. The admin guy at the company said my server was just rebooting and it was up again - I was out of the office when he rang my mobile, but he made a mistake, it's still down.

I tried the 'Reboot' command a few times, but still no luck. So, I think everything is there, just no site. Any idea how to get it back?

Thanks for any help.


share|improve this question

closed as not a real question by MDMarra, Ward, Jenny D, Wesley, Scott Pack May 25 '13 at 21:24

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Something is not clear in your question. You said you sshd into the server after it rebooted and saw all your files there, but then you said that it's down. Which is it? – Michael Hampton May 25 '13 at 0:35
@MichaelHampton It reads as if the VPS is up and running, but the [expected] web site is unavailable. OP should probably indicate which web service they run, how they configured it to startup and what run level they're at, etc. :) – jscott May 25 '13 at 0:42
Is your web server (the daemon) set up to start automatically? – demure May 25 '13 at 1:06
@Michael Hampton - can connect to server, but website is down. – Christophe Harris May 25 '13 at 6:03
@jscott. Not sure about what service I run. A Russian company set it up. Slow to get in touch unless I pay first. I have all priorities, if that's any help. - I'm on plan 2, if that's any help. – Christophe Harris May 25 '13 at 6:12

1 Answer 1

up vote 2 down vote accepted

Check to see if the Apache HTTPD daemon is running:

sudo service httpd status

If it is not running, start the Apache HTTPD service:

sudo service httpd start

Finally, if the Apache HTTPD service wasn't running after restart you'll need to set the service to start automatically on startup:

sudo chkconfig httpd on
share|improve this answer
Hi Adam, thanks for putting me on right track!When I type in 'sudo service httpd status' in terminal I get 'httpd is stopped'. So I type in 'service httpd start'. And I get Starting httpd: [Sat May 25 07:09:02 2013] [warn] module deflate_module is already loaded, skipping [Sat May 25 07:09:02 2013] [warn] NameVirtualHost *:80 has no VirtualHosts (13)Permission denied: make_sock: could not bind to address [::]:80 (13)Permission denied: make_sock: could not bind to address no listening sockets available, shutting down Unable to open logs [FAILED] [app@populisto ~]$ – Christophe Harris May 25 '13 at 6:21
You need to be root to start the service, just incase you did not already do it, try: sudo service httpd start – David Houde May 25 '13 at 7:58
David Houde, you're a legend. It's back now. Thanks a lot. – Christophe Harris May 25 '13 at 9:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.