Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When booting a debian wheezy server using apache2 version 2.2.22, the apache autostart fails with the following error:

Starting web server: apache2(99)Cannot assign requested address: make_sock: could not bind to address [2a01:aaa:bbb:ccc::2]:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.

I already checked if port 80 is already being used by another process using netstat - it is not.

The ipv6 setup is native, not using any tunnels. This is the used /etc/network/interfaces:

iface eth0 inet6 static
  address 2a01:aaa:bbb:ccc::2
  netmask 64
  gateway 2a01:aaa:bbb:ccc::1

I also tried setting the S[xx]apache2 number used by rc.d higher then the ones of all the other process, still the same error.

When later starting apache manually using /etc/init.d/apache2 start over ssh, everything works fine.

How could I possibly fix this?

share|improve this question

1 Answer 1

It sounds as if you're trying to start apache before the network is started. Try starting it at a later time in the boot process.

share|improve this answer
    
I set a ID higher then all the other processes ones in rc.d, still the same error. –  Zulakis May 25 '13 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.