Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a virtual machine, with cent os installed, and everytime I sleep the host computer, the clock of the VM goes out of sync. I would like it to pick up the current time from virtualbox - which I would expect it to do naturally.

How can I force the clock to update from the host machine - or better still, have it stay in sync automatically?

share|improve this question
    
It should sync after a few minutes. If not, why not installing a NTP server on the host? Btw, Are you running Guest Additions? –  SilentStorm May 27 '13 at 7:05
    
I can not get network access to update from NTP server. I am not sure if guest additions is running. I am fairly sure it was installed. The VM has been provided to me at my job. –  Billy Moon May 27 '13 at 7:09
    
I did a small research and everything I found tells that either Guest additions or Virtual Box itself syncs the time without intervention. You may got it disabled. The following command may enable it (Use on host): vboxmanage setextradata <vmname> “VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled” “0″ –  SilentStorm May 27 '13 at 7:13
    
thanks @SilentStorm, that seems to have worked. –  Billy Moon May 27 '13 at 7:39
    
you're welcome. Happy hacking! –  SilentStorm May 27 '13 at 7:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.