Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently I can access my url in this way.

xxxxxx.com/index.php/login

But I want to make it to

xxxxxx.com/login

So I used the following rewrite sequence

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php/$0 [PT,L] 

But xxxxxx.com/login is giving me 404 Not found.

rewrite.load is present in mods-enabled/

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Do you use .htaccess file? please check AllowOverride directive in a Vhost configuration, should be: AllowOverride All.

share|improve this answer

Replace AllowOverride None by AllowOverride in /etc/apache2/sites-available/default .htaccess fils not read by apache, because it's configuration files weren't allowing an htaccess to override previoulsy given instructions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.