Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I took sometime this long holiday weekend to install Hyper-V Server 2012 and Windows 8 Pro (on separate hardware, same LAN) to hopefully get a little more familiar with it. From the WIN8 client I am unable to connect to any VMs using the Virtual Machine Connection or the Hyper-V manager. I get the the following error:

You do not have the required permission to complete this task.

Basically, here are the steps I followed on the HYPERV server:

  • Installed Hyper-V Server 2012 and ran all Windows Updates
  • Disabled the firewall: Get-NetFirewallProfile | Set-NetFirewallProfile –Enabled False
  • Added a local account Goyuix on HYPERV server
  • Ran hvremote.wsf: cscript hvremote.wsf /add:HYPERV\Goyuix

And the WIN8 client:

  • Installed Windows 8 Pro
  • Disabled the firewall: Get-NetFirewallProfile | Set-NetFirewallProfile –Enabled False
  • Added a local account Goyuix on WIN8 client
  • Ran hvremote.wsf: cscript hvremote.wsf /anondcom:grant

When I run the cscript hvremote.wsf /show /target:HYPERV command from the WIN8 client, I get the following message as a failure:

Cannot connect to root\cimv2 on HYPERV

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If you are using a HOSTS file to resolve the server name from the client, you could try making sure to use the server name only and not FQDN, per this:

http://code.msdn.microsoft.com/windowsdesktop/Hyper-V-Remote-Management-26d127c6/view/Discussions#content

Also, check the Windows Security event log to see if there are any additional details about authentication.

Hope that helps.

share|improve this answer
    
I had tried with IP address and it was definitely not happy with that. After rebooting the HYPERV server and connecting by host name things appear to be working. Thanks! –  Goyuix May 28 '13 at 15:28
    
Awesome, thanks for confirming. –  Noah Stahl May 28 '13 at 22:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.