Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would quite like to be running the latest production releases of PHP and MySQL on my production RHEL5.3 server.

PHP so that I can use Zend Framework 1.9 which only supports PHP 5.2.4 or later.
MySQL because they claim 5.1 is faster.

I am a little concerned about installing from RPM's because of breaking dependencies and having to manually keep things up-to-date afterwards.

After a bit of research, I found the Remi Repository.

If I add this to my list of repositories, yum update will be able to upgrade PHP and MySQL.

This sounds too good to be true - so are there any pitfalls or problems that I should be aware of?

share|improve this question

migrated from stackoverflow.com Aug 6 '09 at 19:17

This question came from our site for professional and enthusiast programmers.

    
I'd now recommend IUS Community Project at iuscommunity.org instead of Remi Repository –  Richard Dec 2 '09 at 13:23
add comment

2 Answers

up vote 2 down vote accepted

I do not see why "this sounds too good to be true".

Considerinh PHP 5.2 was released quite a few years ago, the problem is that Redhat/CentOS are really late about that (yeah, I know, "stable" and all that, which means not updating anything except for security reasons)

Happily, some people stepped up, and did the job that had to be done : create the RPM packages that so many of us needed ;-)
Only thing there might be : it won't be "offcial" packages ; so maybe not OK with the policy of your system admins ?

Still, if in doubt : before using those on your production server, you should try them on a test server (if you don't have one, a Virtual Machine will do just fine), just to be sure -- and, also, to check that your application works fine on 5.2


On the other hand, you might want to try compiling PHP by yourself : it is definitly not that hard, and it's a good thing to know :-)

share|improve this answer
add comment

if you install php and mysql from Remi's repository, yum will be able to keep your packages up-to-date.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.