Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A single process is taking 100% of the cpu and 70% of the memory and starts every day on different account;

/usr/local/cpanel/3rdparty/bin/analog +CIMAGEDIR /images/ +CDOMAINSFILE /usr/local/cpanel/3rdparty/share/analog/usdom.tab +CCHARTDIR ./ +CALLCHART ON +CLANGFILE /usr/local/cpanel/3rdparty/share/analog/us.lng +COUTFILE /home/dunstar/tmp/analog/5.html +CLOCALCHARTDIR /home/dunstar/tmp/analog/ +CCACHEOUTFILE /home/dunstar/tmp/analog/cache.out +CCACHEFILE /home/dunstar/tmp/analog/cache +CVHOST ON +COSREP ON +CBROWSER ON +CFULLBROWSER ON +CREDIRREF ON +CREFSITE ON +CFAILREF ON +CLOGFORMAT COMBINED +CHOSTNAME dunstarltd.com +CHOSTURL http://dunstarltd.com/ /usr/local/apache/domlogs/dunstarltd.com.bkup

after i kill the process everything comes back to normal; then after 30-40 minutes another process starts for another account:

/usr/local/cpanel/3rdparty/bin/analog +CIMAGEDIR /images/ +CDOMAINSFILE /usr/local/cpanel/3rdparty/share/analog/usdom.tab +CCHARTDIR ./ +CALLCHART ON +CLANGFILE /usr/local/cpanel/3rdparty/share/analog/us.lng +COUTFILE /home/pisarevo/tmp/analog/5.html +CLOCALCHARTDIR /home/pisarevo/tmp/analog/ +CCACHEOUTFILE /home/pisarevo/tmp/analog/cache.out +CCACHEFILE /home/pisarevo/tmp/analog/cache +CVHOST ON +COSREP ON +CBROWSER ON +CFULLBROWSER ON +CREDIRREF ON +CREFSITE ON +CFAILREF ON +CLOGFORMAT COMBINED +CHOSTNAME pisarevo.com +CHOSTURL http://pisarevo.com/ /usr/local/apache/domlogs/pisarevo.com.bkup 

cpu goes high again; when we kill it all goes back to normal;

When the process starts it takes almost all the resources no matter of the site; the sites are small but have 5-20k visitors daily; the server has 8GB ram; 8 Cores;

How do we stop/deal with this ? - note all backups are currently disabled;

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Analog is a statistics software like Webalizer or Awstats.

http://docs.cpanel.net/twiki/bin/view/AllDocumentation/CpanelDocs/AnalogStats

You can disable Analog from WHM > Statistics Software Configuration

http://docs1.cpanel.net/twiki/bin/view/11_30/WHMDocs/StatsSoftware

At the Generators Configuration uncheck Analog and click save.

This will disable Analog from running again.

You may also want to delete on each user's home directory any analog temp files (they tend to be a lot of MBs, even GBs!) Those will be under /home/_username_/tmp/analog/

share|improve this answer

From doing a bit of searching: http://forums.cpanel.net/f5/process-run-big-memory-195311.html

Looks like it's something called "Analog Stats". You can probably disable this from within cPanel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.