Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a Windows 2008 Server. It has the built-in windows firewall on it. I've played around with the Advanced settings where I can setup inbound/outbound rules, but it doesn't appear that I can create a rule that would say "Block All incoming traffic except traffic coming from this IP address"

I created a rule that Blocks All, but there's no way that I've found to create a rule that will "override" the block rule and allow 1 or more IP's to get in.

I accomplished this on a Win2k box using IPSEC, but it seems that IPSEC is now built-in to windows firewall.

Any tips?

share|improve this question
up vote 4 down vote accepted

Ok, so this ended up being a dumb question.

By default, anything that does not have a rule is automatically blocked by the built-in firewall in Windows server 2008. So to make this work, all I needed to do was add a rule specifically allowing the IP address to get in.

share|improve this answer
True, but there's a lot of stuff allowed by default. I thought you wanted to block everything from everywhere except 1 IP? – TheCleaner Aug 7 '09 at 14:12

With your "inbound blocking rule" already created...

You would create a new Inbound rule (custom rule).

Set it for all Programs and ANY ports...then on the "scope" page you set the bottom "Which remote IP addresses does this rule match" and set the IP specifically for that IP you want to let inbound. Next page leave it as "allow the connection". Next page, allow it to apply to all profiles.

That should do it.

share|improve this answer
This is what I've tried to do. I created a blocking rule that blocks all inbound to all programs. I then create an "allow" rule as you describe, adding my client IP as allowed. All traffic is still blocked unless I disable the first blocking rule. – user2125551 Aug 6 '09 at 20:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.