Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was following this tut on how to set up a EC2 instance on Ubuntu but qhen trying to execute ssh command on my IP address, I had an operation Timeout.

So I tried to ping it but no chance neither. got Request timeout

Any idea what to do to make it working ? Status is green on my dashboard.

Thanks !

share|improve this question
up vote 8 down vote accepted

AWS security groups block ICMP (including ping, traceroute, etc.) by default. You need to explicitly enable it.

share|improve this answer
Does it usually take time for ping to work after I make this change? Coz, I made the change and tried to ping again but I am getting the timeout again! – Raj Pawan Gumdal Feb 23 '15 at 9:14

You need to add a rule to the security group of your server:

In EC2 Dashboard, on "Security Groups", select the group of your instance, click on the "Inbound" tab, select "Custom ICMP rule" in the Type field select "Echo Request" and click "Add Rule".

share|improve this answer

In security group from AWS console you need to allow port 22 and by default ICMP is blocked on AWS , so if you want to enable ping you need to allow ICMP too.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.