Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

named.conf.local (included in named.conf)

zone "" {
    type master;
    file "/var/lib/bind/";

DNS zone

$ttl 600    IN  SOA server.hostname. mail.server.hostname. (
            600 )    IN  NS  server.hostname.

fake            A

dig test

dig +trace
[...]             600     IN      SOA     server.hostname. mail.server.hostname. 1369844282 600 600 600 600

Why fake is not resolved? What i'm missing?

Some more details

DNS for this server are managed from a domain panel on a hosting.

On that DNS panel i've set a subdomain as NS record pointing to the server.

Hosting DNS Panel Records

@           A     
www     A     
ftp     A         
beta    A
_domainkey  NS

So, when i talk about the fake record, i mean that dig can't resolve because, as already said, answer me with the SOA and not with the record.

share|improve this question

2 Answers 2

Have you tried reloading bind after making those files?

I'm not sure what your OS is, but one of these should do the trick:

$ rndc reload


killall -HUP named

These will reload the config without taking the service down. Barring that, the nuclear option:

service named restart


/etc/init.d/named restart

share|improve this answer
yes, thank you. I've already reloaded the zone. Now i've tried a bind9 restart (i'm on Ubuntu 12.04) but nothing, I keep to reach only the SOA –  apelliciari May 29 '13 at 22:55
Have you verified that the zone is loading properly? Check the output of the commands named-checkzone /var/lib/bind/ and named-checkconf -z, and check the name server's log file for errors on startup. –  This isn't my real name May 30 '13 at 0:39
yes, everything seems regular :( –  apelliciari May 30 '13 at 7:39
up vote 1 down vote accepted

the issues was in the _domainkey NS record in the hosting DNS panel, because it didn't work properly.

i've added the records directly in the DNS hosting panel and it works fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.