Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have my own server. When client uploaded a file to my server through FTP, the permission of the file uploaded is 755. It means if client uploaded a file to my server, client cannot modify the file uploaded to server immediately and have to wait for me to permit the file uploaded to 777.

How can I make the file uploaded from client with permission 777 so that client can modify the file after uploaded.

I am using ubuntu 10.04 and vsftpd FTP server.

share|improve this question
    
What are the permissions of the folder the files are going into? –  Nathan C May 30 '13 at 11:08
    
Do you want that for all files or just for one / some? –  Hauke Laging May 30 '13 at 11:14
2  
FYI: 7 == Read, Write and EXECUTE Are you SURE you want them to be able to do that? –  Chris Nava May 30 '13 at 14:40
2  
More to the point, are you sure you want everyone to be able to modify everyone else's files? –  Michael Hampton May 30 '13 at 15:15
6  
@edisonTHK STOP. Do absolutely nothing until you go read the Wikipedia article on Unix file permissions and fully understand what they mean. Blindly changing file permissions like they're some kind of magic voodoo ritual is NOT the way to administer a server. You'll wind up breaking things, creating security holes, or both. –  voretaq7 May 30 '13 at 18:31
show 5 more comments

closed as off topic by mdpc, Chris S May 30 '13 at 18:36

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 0 down vote accepted

"file_open_mode" is the option you're looking for, check it out in the VSFTPD man pages. Also keep in mind that the "local_umask" option is also affecting the actual permission.

This should do the trick.

local_umask=000
file_open_mode=0777
share|improve this answer
    
Nice answer, I will give your a check after I have tried it! By the way, Could it done only with the specified directory? –  edisonTHK May 30 '13 at 12:20
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.