Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem in one of my servers. I have a SLES 11 server and I have bond (bond0) two ethernet cards (eth0 and eth1). i setup mtu to be 9000 on all interfaces. When i reboot the server the mtu change to the default value 1500 and i have to run manually the command ifconfig ethA mtu 9000 up to all the interfaces.

I want to create a script that will run everytime the system reboots.

It is normally not my job to write init-scripts, since I expect the system to behave "right". In this case I set MTU in yast2to 9000 but it does not work.

share|improve this question

closed as off topic by mdpc, Ward, Scott Pack, Falcon Momot, kce May 31 '13 at 16:49

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Yes - I came across that on SLES11 SP3 as well. You have to solve this with an own init-script indeed. –  Nils Jan 29 at 9:46
add comment

1 Answer

up vote 3 down vote accepted

Modify /etc/init.d/boot.local to add what you want.

share|improve this answer
    
Thanks Nathan for your quick response. I make the necessary changes at boot.local but when i reboot the server i had the same situation. I run the command who -r and i saw that i run at level 5. Do you know if i have to copy the specific file into rc.5d? –  Spiros P May 31 '13 at 12:06
    
It should work without doing that. Try using "sudo" with the command as well. –  Nathan C May 31 '13 at 12:13
    
So inside the boot.local i will run only the following? sudo -u root ifconfig eth0 mtu 9000 sudo -u root ifconfig eth1 mtu 9000 sudo -u root ifconfig bond0 mtu 9000 –  Spiros P May 31 '13 at 12:36
    
Correct. If that doesn't work, there's also an after.local that runs after everything else has started. You'll have to create this file in the same init.d folder. –  Nathan C May 31 '13 at 12:37
    
Do you know how to create that file? Sorry if i bother you but i have stuck three days about that. –  Spiros P May 31 '13 at 12:46
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.