Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using a fresh installed CentOS 6.4 (x86-64) with the EPEL repository.

$ yum install nodejs
...
$ node -v
v0.10.5

So far, so good, but when I try to install npm, I'll get this error message:

$ yum install npm
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: ftp.halifax.rwth-aachen.de
 * epel: mirror.fraunhofer.de
 * extras: centos.psw.net
 * updates: centos.psw.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package npm.noarch 0:1.2.17-5.el6 will be installed
--> Processing Dependency: npm(which) < 2 for package: npm-1.2.17-5.el6.noarch
--> Processing Dependency: npm(uid-number) < 1 for package: npm-1.2.17-5.el6.noarch
--> Processing Dependency: npm(tar) < 0.2 for package: npm-1.2.17-5.el6.noarch
--> Processing Dependency: npm(slide) < 2 for package: npm-1.2.17-5.el6.noarch
--> Processing Dependency: npm(semver) < 1.2 for package: npm-1.2.17-5.el6.noarch
...
(skipped)
...
--> Finished Dependency Resolution
Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel)
           Requires: npm(ansi) < 0.2
Error: Package: npm-1.2.17-5.el6.noarch (epel)
           Requires: npm(ansi) < 0.2
Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel)
           Requires: npm(ansi) >= 0.1.2
Error: Package: npm-1.2.17-5.el6.noarch (epel)
           Requires: npm(ansi) >= 0.1.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The complete output is quite big: http://pastebin.com/raw.php?i=Ce3ZJsEB

What should I do? The --skip-broken workaround doesn't seem to be right solution.

Here is the output of yum repolist:

Loaded plugins: fastestmirror, refresh-packagekit, security
Determining fastest mirrors
 * base: centos.copahost.com
 * epel: mirror.fraunhofer.de
 * extras: ftp-stud.fht-esslingen.de
 * updates: centos.copahost.com
 repo id       repo name                                            status
 base          CentOS-6 - Base                                      6,381
 epel          Extra Packages for Enterprise Linux 6 - x86_64       8,909
 extras        CentOS-6 - Extras                                       12
 updates       CentOS-6 - Updates                                     727
 repolist: 16,029
share|improve this question
2  
what is your 'yum repolist'? –  Andrei Mikhaltsov May 30 '13 at 16:28
    
@AndreiMikhaltsov I added the output of yum repolist –  Philipp Claßen May 30 '13 at 16:35
    
I think you skipped the part we need to see: --> Processing Dependency: npm(ansi) ... –  Aaron Copley May 30 '13 at 16:39
    
@AaronCopley I ran the command again. The output is availabe here: pastebin.com/raw.php?i=Ce3ZJsEB (I also edited my post to insert the link.) –  Philipp Claßen May 30 '13 at 16:57
    
What happens when you install nodejs-ansi first? yum install nodejs-ansi –  etagenklo May 30 '13 at 17:04

1 Answer 1

up vote 5 down vote accepted

Package nodejs-ansi from EPEL (nodejs-ansi-0.1.2-7.el6.noarch) is broken.

Try:

wget http://kojipkgs.fedoraproject.org//packages/nodejs-ansi/0.1.2/7.el6.1/noarch/nodejs-ansi-0.1.2-7.el6.1.noarch.rpm
yum --enablerepo="epel" install npm ./nodejs-ansi-0.1.2-7.el6.1.noarch.rpm

Solution founded on #epel at irc.freenode.net.

See also: http://pastebin.com/mqFqRqUp line 28

share|improve this answer
1  
Solved my problem. But minor typo on "eneblerepo" vs "enablerepo". –  rlorenzo May 30 '13 at 22:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.