Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Virtual Machine running Windows XP. I added Remote Desktop exception in Windows Firewall.

I'm trying to connect via Remote Desktop using the ip address that I get running ipconfig in the VM. But that doesn't work.

I'm trying to connect using the machine that's running the VM but I also want to connect with other machines.

What am I missing?

share|improve this question

4 Answers 4

Have you enabled Remote Desktop in the system properties?

Start > Control Panel > System > Remote > Allow users to connect remotely to this computer

Are you trying to connect to the machine from the host machine (i.e. the machine the VM is running on), or another computer on the network?

share|improve this answer
    
I enabled the Remote Desktop in system properties. I'm trying to connect from the host machine. But I want to connect from another computer on the network, too. –  Daniel Moura Aug 6 '09 at 21:28
    
Refer to Evan Anderson's answer. He's said exactly what I was about to say. –  Mark Henderson Aug 6 '09 at 22:45

You don't mention what virtualization software you're using, but your comment to Farseeker makes it sound like you've got the VM connected to a "host only" network. If you want the VM to talk to other hosts on the LAN, configure it to use "bridged" networking (in VMware parlance) and allow it to pull DHCP (if you use DHCP) or assign the VM a LAN-side IP address.

If you can't PING other LAN hosts in the VM you're not going to be able to use RDP to connect to the VM. Start troubleshooting inside the VM first. After you've configured it for bridged networking and established that it has a LAN IP address see if it can PING its default gateway. If it can then you're probably "in business" as far as connecting to it from other LAN hosts.

share|improve this answer
    
I'm using Sun xVM VirtualBox –  Daniel Moura Aug 6 '09 at 21:40
    
I have no experience with VirtualBox, but the term you're looking for with it is "Host Interface networking" in the version 2 releases. In the version 3 releases, it looks like they're calling it "bridged". See here for some details on version 3: virtualbox.org/manual/UserManual.html#networkingdetails –  Evan Anderson Aug 6 '09 at 22:28

You have to enable internet connection sharing on the network adapter i think. Also, make sure your VM acquires an IP on a subnet that is accessible from the Terminal Services client computer.

share|improve this answer

If you have the VM set up to use NAT networking, then you can use vboxmanage to set up port forwarding to it. Search its help (or the web) for the Configuring port fowarding with NAT article.

Terminal Services (ie. Remote Desktop) communicates on port 3389 by default. You probably want to keep that port on the host OS free, so I suggest setting it up to forward the host port 33890 (for example), to the guest port 3389. Then, make sure VirtualBox itself can communicate through the host OS's firewall, and you can RDP to it by specifying the port number (to do that append it after a colon to the address of the machine you're remoting to, eg. hostpc.domain.com:33890

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.