Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After updating Fedora 18 to kernel 3.9.x (current 3.9.4), I can no longer boot my Centos 5 guest OS. When I try to boot, the process halt at start and the CPU core work at 100%.

If I boot Fedroa (host) using kernel 3.8.x everything work as expected.

Guest console

The command is:

/usr/bin/qemu-kvm -name MyGuestCentos5 -S -M pc-0.14 -cpu Nehalem,+rdtscp,+xtpr,
+tm2,+est,+vmx,+ds_cpl,+monitor,+pbe,+tm,+ht,+ss,+acpi,+ds,
+vme -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,
threads=1 -uuid 8502e6b9-993e-4e51-f3e4-613131379e51 -no-user-config -nodefaults -chardev socket
,id=charmonitor,path=/var/lib/libvirt/qemu/MyGuestCentos.monitor,server,
nowait -mon chardev=charmonitor,id=monitor,
mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,
id=usb,bus=pci.0,
addr=0x1.0x2 -drive file=/var/lib/libvirt/images/MyGuestCentos_centos5-clone.img,
if=none,id=drive-virtio-disk1,format=raw -device virtio-blk-pci,scsi=off,
bus=pci.0,addr=0x6,drive=drive-virtio-disk1,id=virtio-disk1,bootindex=1 -netdev tap,fd=22,
id=hostnet0,vhost=on,vhostfd=23 -device virtio-net-pci,
netdev=hostnet0,id=net0,mac=52:54:00:5f:13:a3,bus=pci.0,addr=0x3 -chardev pty,
id=charserial0 -device isa-serial,
chardev=charserial0,id=serial0 -vnc 127.0.0.1:0 -vga cirrus -device virtio-balloon-pci,
id=balloon0,bus=pci.0,addr=0x5
share|improve this question
    
I'd suggest managing your VMs with libvirt + virt-manager + virt-viewer to avoid the unnecessary work of typing such long commands and to try to reproduce the same problem. –  dawud May 31 '13 at 17:33
    
dawud, I agree. I actually use virt-manager. this the process I get when issuing ps auxw –  michaelbn Jun 1 '13 at 11:52

1 Answer 1

up vote 2 down vote accepted

I'm facing same issue, and I just found this bug: https://bugzilla.redhat.com/show_bug.cgi?id=967652

Workaround mentioned in bug works for me:

modprobe kvm_intel emulate_invalid_guest_state=0
share|improve this answer
    
Thanks man, that worked. Important note: it only worked after I first removed the module using: rmmod kvm_intel –  michaelbn Aug 9 '13 at 7:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.