Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So, I have a very old classic ASP site which uses some VB6 dll to do some "stuff". one of the things is to search for files in a directory and then some other operation things with that file.

The old site works just fine and that is using IIS6. It can access the UNC path and brings me back the correct results.

The new ASP.NET site, hosted in IIS7.5 does not quite work. Using the same DLL, I get no results back from it. Looking at the Last Win32 Error, it gives me file or path not found.

However, in the AppPool - if I change to use my domain account, guess what? It works no problem! Why would this be? How can I make it see the UNC path and make it work like the old site?

The VB6 dll and operations has got nothing to do with me nor does anyone have the source code but the source code is not the problem here. The problem is to do with IIS and authentication. At least in that region/area.

I am stumped and deployment has been delayed for a week now because of this unfortunate issue.

I can access \server\Share\ using my domain creds. But when IIS is being used and using the ApplicationPoolIdentity account (I've tried Network Service too and the others), it fails to find it altogether when the website is running.

When I change the AppPool to use my domain creds - works no problem. But this I believe is NOT the solution to the problem.

I've also tried \IP.Address\Share but still does not work.

Thoughts? What am I missing here? What have I not set up correctly?

share|improve this question
    
Does the AppPool account have permissions to the share? –  Nathan C May 31 '13 at 15:24
    
Hi Nathan. No it does not. But I dont think the other server running IIS6 does either. How would you then add the permissions for the AppPool account to a share that is on the network hosted on another file server which is not the same as the website? –  Ahmed ilyas Jun 1 '13 at 12:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.