Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was wondering if anyone had success in configuring Amazon Linux to authenticate to an LDAP server?

EDIT:
For more information on what I have done:

I disabled anonymous access on my OpenLDAP server, so I am trying to have my openldap client on Amazon Linux connect to the OpenLDAP server with a binddn to authenticate. But when I check the logs on the OpenLDAP server, the binddn is empty. I have added my binddn and bindpw to /etc/pam_ldap.conf.

Part of my /etc/nsswitch.conf

passwd:     files ldap
shadow:     files ldap
group:      files ldap

my /etc/pam_ldap.conf

base dc=example,dc=com
bindnd uid=test_client,ou=System,dc=example,dc=com
bindpw secret
scope sub
pam password md5

nss_base_passwd ou=System,dc=example,dc=com?one
nss_base_passwd ou=People,dc=example,dc=com?one
nss_base_shadow ou=People,dc=example,dc=com?one
nss_base_shadow ou=System,dc=example,dc=com?one

tls_checkpeer no
uri ldap://ec2-00-00-00-00.compute.amazonaws.com
ssl no
tls_cacertdir /etc/openldap/cacerts
share|improve this question
    
I haven't tried, but I don't see why not.. What've you tried? If you post what you've tried, I'll throw together an EC2 instance and have a go.. –  Tom O'Connor May 31 '13 at 20:00
    
I've used authconfig-tui and selected use ldap and Use LDAP Authentication. And then I tried to add my binddn to /etc/pam_ldap.conf but when I try to ssh into the Amazon Linux machine with a uid in my LDAP server, the LDAP server receives a blank binddn. And I disabled anonymous binding and required authc on my LDAP server –  Hank May 31 '13 at 20:09
    
Can you post some bits of your config? /etc/nsswitch.conf, /etc/ldap.conf, /etc/ldap/ldap.conf and /etc/pam.d/common-* –  Tom O'Connor May 31 '13 at 20:18
    
I don't have /etc/ldap.conf, but have /etc/pam_ldap.conf. And I changed some of the values to protect my privacy. –  Hank May 31 '13 at 20:32
    
I was using LDAP authentication with autofs for at least 7 years in Amazon cloud. I will check my notes and will post it here once I get home. –  dtoubelis May 31 '13 at 20:36

1 Answer 1

up vote 0 down vote accepted

I got it working by configuring /etc/nslcd.conf with my binddn and bindpw

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.