Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've had a software RAID1 array in production for over a year which has LVM partitions on top of /dev/md0. I rebooted over the weekend to apply some kernel patches and now the array won't come up. Getting the "Continue to wait; or Press S to skip mounting or M for manual recovery" on boot. I hit M, login as root, and the RAID array is up, but none of the LVM partitions are available. It's like everything is gone. I stopped the array and brought it up on a single disk (it's RAID1) with --run. Ok, the lvm stuff is there now. So I added a new disk and add it to the degraded array. It starts rebuilding. I do an fdisk of the new disk I just added and there's a brand new partition there of type 'Linux LVM'. I did not add that partition. What's going on? I'm not even using partitions, I'm just using the raw devices.

share|improve this question
1  
Someone put that partition table there. I bet this is a Debian-derived system. BTW, it's a bad idea to use the raw devices as RAID members, for exactly this reason. –  Michael Hampton Jun 2 '13 at 2:56
    
What's the significance of Debian mean in your statement? Is there a long-standing issue with Ubuntu that I don't know about? As far as using the raw devices, why? The RAID wiki says it's perfectly OK (raid.wiki.kernel.org/index.php/Partitioning_RAID_/_LVM_on_RAID) here is a working example that would result in a partitionable device made of two disks -- sda and sdb: I've tried building the RAID device using partitions of type FD and as soon as I put the LVM over /dev/md0, it turns the FD types into LVM. I finally said screw it and hard partitioned. That worked. –  Server Fault Jun 3 '13 at 14:21

1 Answer 1

up vote 0 down vote accepted

Only way I could get the software raid array stable was to leave LVM off and hard-partition. I tried using both raw devices, as well as type 0xFD partitions and as soon as I tried using LVM across /dev/md0, the partition types would automatically change from 0xFD to "LVM" on all the raid members. Very, very strange. I've been using LVM over Linux software RAID for nearly a decade and have never seen this problem before. I'm buying an Areca card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.