Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using a FallbackResource directive to implement a front controller. Apache should redirect all requests to index.php in the document root, unless there is a file at the requested URI. This is exactly what it does, unless the request URI is /; then I get a 324 No Data Received error. Even with LogLevel debug, nothing is logged when this error happens.

I am using Apache 2.2.22 on Ubuntu for local development, with mod_dir enabled.

I just wanted to check if anyone can see a problem here, before I go and compile the latest Apache 2.2 and file a bug report.

Virtualhost config:

<VirtualHost *:80>
    DocumentRoot /var/sites/scms/www
    ServerName scms.local
    ServerAlias www.scms.local

    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>

    <Directory /var/sites/scms/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride FileInfo
        Order allow,deny
        allow from all
        FallbackResource /index.php
    </Directory>

    <Directory /var/sites/scms/www/resources/>
        FallbackResource disabled
    </Directory>

    ErrorLog /var/sites/scms/log/error.log
    CustomLog /var/sites/scms/log/access.log combined

    LogLevel debug

</VirtualHost>
share|improve this question
    
I am experiencing the same problem. Another thing (from the docs): Compatibility: Apache HTTP Server 2.2.16 and later - The disabled argument is supported since 2.2.24 –  andsens Oct 30 '13 at 12:24
add comment

1 Answer

I experienced same problem, so it is probably a bug. However, I managed to solve it using "DirectoryIndex" directive:

DirectoryIndex /index.php
FallbackResource /index.php
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.