Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to schedule an application which should run on every night on windows 2008 Server. After I schedule the application When it is above to execute everytime it is displaying prompt whether to allow the application to install or not.

Is there any way to avoid the prompt ,because the application has to start every morning 4 AM .

Any suggestions or thoughts are welcome.

share|improve this question
    
More details about what application you're trying to run would be a big help to figure out a good solution. –  romandas Aug 7 '09 at 2:31
    
Thanks for the Reply .I just want to execute a .Exe file –  Riya Aug 7 '09 at 2:33
    
This sounds like either the prompt you receive when trying to run a program that has been downloaded from the internet with IE or a UAC prompt for an application that requires elevated privileges. –  shufler Aug 7 '09 at 17:39

5 Answers 5

Have you tried running the application once manually to allow it to install whatever it needs, then scheduling it for subsequent runs?

This sort of behavior is much like how MS Office 2003 works. Once you allow it to run its installer the first time, you don't see it again.

share|improve this answer
    
I am trying Run a .Exe file. After i schedule the .Exe application If i click on the allow prompt ,It will execute .But My problem is after i scheduling the job every night it will ask whether to install the application or not . My concern is it should not display the prompt –  Riya Aug 7 '09 at 2:37
    
If you run the .exe yourself does the 'allow' prompt appear everytime or only the first time you ran? Have you tried running the .exe from the command line with a /? switch, perhaps there is a 'silent' option? –  PaulPlum Aug 7 '09 at 9:14

Ensure you run the application at least once, as romandas suggested, and make sure you do so using the user account which will be used to run the application via the task scheduler.

share|improve this answer
    
This was going to be my next suggestion. –  romandas Aug 7 '09 at 16:38

If the .exe needs administrative privileges and you're using an elevated account to run it, you need to make sure that you check the "Run with Highest Privilege" box on the task creation page.

share|improve this answer

Does this ".EXE file" rely on some settings - for instance in the registry-database or user-folder - to know if it is installed or not?

If it does, make sure that the settings or folder-contents is not deleted/removed/cleaned by some other automatic rule or application.

share|improve this answer

Here's my few cents:

1.) Find out if it has any command line switches for a force install, or to force a yes to the question.

2.) Write a batch script that calls the .exe (probably use start prog.exe) using the switches from 1.

3.) Schedule the batch script using AT.exe so it will run as the system account. For the usage open up a command prompt and use at /?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.