Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a pool of 3 servers with XCP only, each with 1 VM running on them, and managing them through XenCenter. Since the opensource version of xen does not have support for HA, I am using HA-lizard, and installed it to each server.

When I restart the master I am expecting one of the slaves to pick up the role of master and XenCenter to reconnect to the promoted slave, but that does not happen. Instead, XenCenter keeps attempting to connect to the old master, which fails. The VM's get migrated (as best I can tell) but the real issue is between the Master and Slave.

Anyone have experience in this?

share|improve this question
add comment

1 Answer

If the autoselected slave becomes master, XenCenter would not normally connect to the new master automatically. It would, however, notify you once it connects to the former Master (which is now a slave) and prompt you that a new pool Master has been detected and will ask whether you want to connect to the new pool master. This is the behavior when using the default settings.

Your installation of HA-Lizard may need to be tuned. The default settings are very conservative. Full HA can be achieved by enabling fencing. This approach is intended for production environments and may forcefully remove failed hosts from the pool, which may not be what you are looking for.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.