Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have private network service between a data center and my office location. After moving a server from the office to the data center, we noticed significant packet loss. This greatly affects the speed of our file sharing (SMB is particularly affected).

The Data Center engineers suggested that our switches we set to 100mbps but we only have a 30mbps pipe in the private network so up to 70% of the packets could be lost at the switch.

We tried setting the ports to 10 mbps but they could not connect. Could QoS bandwidth throtling be used in this case? We are using Dell PowerConnect 6224 at the office and PowerConnect 5424 at our Data Center.

Any ideas on how to resolve this?

share|improve this question
2  
I don't really have a specific answer but 70% of packets being lost going from a 30mbps service to a 100mbps port sounds like total crap. What kind of connection do you have between the sites? Is this an MPLS connection, Metro-ethernet? –  Kevin Kuphal Aug 7 '09 at 3:35
    
Total crap indeed. TCP simply doesn't work like this. –  Izzy Aug 7 '09 at 5:20

1 Answer 1

Your data engineers meant to set your server's interface to 100baseTX, the question to ask them now is which duplex should the interface be set to: Full or Half-Duplex. You'll see these kinds of packet loss issues with host's network interface Duplex Mismatches.

There are issues with duplex auto-negotiation, (Which lets the interface decide which speed matches best with the connecting NIC). You can read here about it before making that decision as to what setting to use: http://kb.pert.geant.net/PERTKB/DuplexAndAutoNeg

share|improve this answer
    
Thanks for the input. I've now made sure that every item from the branch office switch to the file server is set to 100M Full with AutoNeg Disabled and I still see packet lose and files are very slow to transfer. The problem does seem to match the symptoms described in the links you provided, but even after checking all the ports on the switchs and the servers network adaptor, I still see the same problem. Is there anywhere else I could look? –  Ross Aug 7 '09 at 11:51
    
That changes the topic of discussion. You'll need to see, based on your logical topology, where you're seeing the packet loss. Client to client? Client to server? Server to server? Going through a specific switch? Also, you'll need to consider what kind of technology is implemented on your switches (STP, QoS/CoS, other kind of packet shaping/limiting). There are a bunch of tools that will help you test for packet loss: Wireshark (to see what's happening inside your network), iPerf (bandwidth tests), mtr(winmtr). Also check if you're not oversubscribing your BW at the border router. –  l0c0b0x Aug 7 '09 at 17:54
    
Thanks again for your feedback. I ran Wireshark on the File Server to see if it does anything different and it seems that almost every response from the File Server is a Trans2 Response that says: Header checksum: 0x0000 [incorrect, should be 0xc7de] The expected checksum changes in each one but the recieved checksum is always 0x0000. Does this sheed some light? –  Ross Aug 10 '09 at 8:27
    
No, that's normal. The issue is probably still a duplex mismatch somewhere. Confirm the duplex settings with the network provider. Perhaps you locked the speed on your end, disabling auto, causing their side to fall back to half duplex. –  David Schwartz Aug 29 '11 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.