Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with a newly installed MySQL box:

When trying to access the database with multiple clients and a lots of retries, sporadically, connecting takes longer than 3 seconds. I only get this behaviour when I try to connect over tcp (no matter if the client is local or remote). If this state is reached, every connection, regardless of the port, takes 3 seconds.

I tried to reproduce this behaviour on another server, but neither the old database server nor the new slave show this behaviour (which to me doesn't make any sense, since master and slave are running on the same OS, the same patch level, the same database version, the same config...)

Searching the internet, I found a link to an email that describes exactly what I experience:, but I couldn't find any solutions.

Does anyone have any experience that could explain this?

Best Regards,


Edit: Before anyone asks: it's not a DNS issue, we set skip-name-resolve as a default in every new MySQL installation.

share|improve this question
up vote 2 down vote accepted

on the server box run tcpdump on lo and on network interface. what does it show ?

can it be some wiredness in authentication [ eg ldap / nis lookup on server that does not respond ] ?

ps - maybe you have not seen this.

edit apparently in this case last one was the solution. apparently kernels < ~ have some bug when ipv6 is disabled that results in 3 sec delay for this specific case.

share|improve this answer
I love you! We switched from RHEL5 (Kernel 2.6.18) to Ubuntu 9.0.4 (Kernel 2.6.28) and the problem is solved! Thank you! – Dan Soap Aug 7 '09 at 14:25
You should edit the answer to make it clear the solution is hidden in that ps. Bug specific to linux kernel version. – jmanning2k Aug 7 '09 at 20:27

Is IPV6 enabled? I've seen similar problems and traced it back to IPV6. I can't quite remember how I got there, but it's definitely at the tip of my brain.

share|improve this answer
Yes, we also ran over a blog or forum post in which IPv6 was described as being a problem. But we checked our configuration and it looked as if that was not our problem. – Dan Soap Aug 10 '09 at 5:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.