Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure a Debian vServer to relay mails for multiple domains pointed to the vServer. The vServer has a fixed ip. The webserver for all domains is working fine.

With one domain the relaying is working as expected but I can not add another domain to uptedate-exim4.conf.conf. It keeps saying:

/etc/exim4/update-exim4.conf.conf: 20: domain2.com: not found /etc/exim4/update-exim4.conf.conf: 23: domain2.com: not found

What is it trying to tell me? Where is it looking for domain2.com? Why does it always work for domain1.com?

dc_eximconfig_configtype='internet'
dc_other_hostnames='domain1.com';'domain2.com'
dc_local_interfaces='0.0.0.0'
dc_readhost=''
dc_relay_domains='domain1.com';'domain2.com'
dc_minimaldns='false'
dc_relay_nets=''
dc_smarthost=''
CFILEMODE='644'
dc_use_split_config='true'
dc_hide_mailname=''
dc_mailname_in_oh='true'
dc_localdelivery='mail_spool'

Note: The configuration is probably not doing what I want it to but I can not test it because of this problem.

share|improve this question

1 Answer 1

Just realized the problem, the whole list has to be quoted, not every single domain. Like so:

'domain1.com;domain2.com'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.