Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a dedicated 30Mb connection (up/down) from our ISP, but we can only seem to get 10Mb (up/down) from the router. Does anyone know what we're missing, or how we can tweak the settings on this router to fully utilize the 30Mb connection. I've already gone rounds with the ISP, and they insist that it's a problem with the router.

Current configuration : 6907 bytes
!
! Last configuration change at 19:20:05 UTC Fri Jun 7 2013 by idirouter
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname idirouter
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
memory-size iomem 10
!
crypto pki trustpoint TP-self-signed-3518923209
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3518923209
    revocation-check none
    rsakeypair TP-self-signed-3518923209
!
!
crypto pki certificate chain TP-self-signed-3518923209
    certificate self-signed 01
    3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
    69666963 6174652D 33353138 39323332 3039301E 170D3133 30363036 31323532 
    35365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
    4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35313839 
    32333230 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
    8100ACF2 553DE11F 40984A24 70C60141 E21282FE 0137C6F8 AD6E87FC 51144491 
    87071884 E9CD7B3A 3489ABF8 E2A83A82 CDC4510E B01ABFD9 2DF4B621 180DC877 
    7F7FD848 2C29884D 560CD54D 1DCEE9DF F0FC9E53 D8646E59 9B35D355 E55FDA10 
    C6B3E84B ED0053AE 121E49CC CEFF041F 9B0E0538 5A84CF1C 36F3B450 09F75E92 
    C4F30203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
    551D2304 18301680 140579A1 61CC6B18 9D3647CD 8ACDF6A1 944BCF83 EA301D06 
    03551D0E 04160414 0579A161 CC6B189D 3647CD8A CDF6A194 4BCF83EA 300D0609 
    2A864886 F70D0101 05050003 8181008B 0F3C9D3C EC08E62D D1DF7D9E 49794739 
    BF351F48 C4843E13 E4018C58 F6B9D588 5853A4BD E97461ED DFDF0E9C F710ECD0 
    4A6935D6 D47DFBBC AF41046C EABA6820 4B7A5CC9 A611E07A 2FAEAC2A 944275CB 
    96D5371D 892DA9A5 6D47F36D A7579199 9EECC5D3 F90AE1E3 AEBC9A15 824425E8 
    F1A8D0FA 23EE3A2B 4D8C756D 2C797D
    quit
!
!
!
!


!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.49
ip dhcp excluded-address 192.168.0.151 192.168.0.254
!
ip dhcp pool pool1
    import all
    network 192.168.0.0 255.255.255.0
    dns-server 192.168.0.1 
    default-router 192.168.0.1 
!
!
!
ip name-server 216.144.187.101
ip name-server 216.144.187.199
ip name-server 204.186.80.251
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO881-SEC-K9 sn FTX171980ES
!
!
username idirouter privilege 15 secret 4 NErxSgSwD6CdGtGORvRbRxhhy3yTMvRxh4luPVIdEZ6
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
interface FastEthernet0
    no ip address
!
interface FastEthernet1
    no ip address
!
interface FastEthernet2
    no ip address
!
interface FastEthernet3
    no ip address
!
interface FastEthernet4
    description $FW_OUTSIDE$$ETH-WAN$
    ip address #EXTERNAL_IP# 255.255.255.252
    ip nat outside
    ip virtual-reassembly in
    ip verify unicast reverse-path
    duplex full
    speed 100
!
interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 192.168.0.3 1008 interface FastEthernet4 1008
ip nat inside source static tcp 192.168.0.3 1009 interface FastEthernet4 1009
ip nat inside source static tcp 192.168.0.190 20 interface FastEthernet4 20
ip nat inside source static tcp 192.168.0.190 21 interface FastEthernet4 21
ip nat inside source static tcp 192.168.0.3 1080 interface FastEthernet4 1080
ip nat inside source static tcp 192.168.0.6 1110 interface FastEthernet4 1110
ip nat inside source static tcp 192.168.0.20 7979 interface FastEthernet4 7979
ip route 0.0.0.0 0.0.0.0 #EXTERNAL_GATEWaY#
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 remark SDM_ACL Category=2
access-list 2 permit 192.168.0.0 0.0.0.255
!
!
control-plane
!
!
!
line con 0
    no modem enable
line aux 0
    modem InOut
    stopbits 1
    speed 115200
    flowcontrol hardware
line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
!
!
end
share|improve this question
add comment

3 Answers

The configuration is pretty straightforward, but two items pop out:

1.) Are you positive that your ISP has instructed you to lock speed/duplex? A mismatch in this area will cause major performance problems.

2.) If the interfaces are OK then try turning off rpf checking, replacing it with an ACL blocking traffic from your local network (really any RFC1918 addresses) inbound on your external interface.

share|improve this answer
add comment

It may be an issue with the routers performance. The 800 series routers generally are pretty slow.

This document rates the 880 series at 25Mbs... if you are getting 10 up AND down that might account for what you are seeing.

Can you test the speed with a laptop directly connected to the ISPs link to see what you get?

share|improve this answer
add comment

rnxrx might be on the right track. You have fe4's speed and duplex set to 100 full. I have seen ISP modem's speed and duplex set to auto and a device set to 100 full not negotiate correctly and fall back to 10 half or 10 full.

It doesn't make sense but I've seen it happen. Try setting fe4 to auto and run your speed tests again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.