Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have been having some issues setting up my godaddy wildcard SSL cert on a new Debian 7 server running Apache 2. Thinking maybe I have missed something and hoping you can help me out. Here is what I have done so far:

  • Turned on SSL mod for Apache: sudo a2enmod ssl sudo service apache2 restart
  • Made sure "Listen 443" was in /etc/apache2/ports.conf
  • Generated my key using openssl: openssl req -new -newkey rsa:2048 -nodes -keyout yourdomain.key -out yourdomain.csr
  • Setup godaddy SSL Cert and downloaded ssl files (gd_bundle.crt & mydomain.crt).
  • Uploaded godaddy files to my server via ftp and copied them to somewhere more safe.
  • Updated /etc/apache2/sites-available/default-ssl with the following:

    SSLCertificateFile /etc/apache2/ssl/mydomain.csr

    SSLCertificateKeyFile /etc/apache2/ssl/mydomain.key

    SSLCertificateChainFile /etc/apache2/ssl/mydomain.crt

    SSLCACertificateFile /etc/apache2/ssl/gd_bundle.crt

  • And made sure it has: SSLEngine on
  • And then restarted Apache: sudo service apache2 restart

When I access the domain via https:// I get this error in chrome: Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

And nothing shows up in my apache error logs.

Any help is GREATLY appreciated.

share|improve this question
    
How did you configure your virtual hosts? What's the URL you tried to access? –  Michael Hampton Jun 8 '13 at 5:50
    
The virtual hosts were all done automatically by the system (I'm new to setting up linux servers but it seems like this is a fairly new feature - Debian 7? - from online resources I have read). URL is orderly.ca –  codephobia Jun 8 '13 at 5:54
    
Your server just disconnects without sending anything. Are you quite sure you enabled the default-ssl virtual host? –  Michael Hampton Jun 8 '13 at 5:59
    
That could be the missing step. –  codephobia Jun 8 '13 at 6:08
1  
Wanted to point out that I fixed this error. Was pointing to the CSR file for some dumb reason instead of the CRT file for SSLCertificateFile. –  codephobia Jun 8 '13 at 6:37

1 Answer 1

up vote 2 down vote accepted

I looked at a connection to your site in Wireshark, and the server immediately disconnected after my client began the SSL negotiation. This leads me to believe you don't actually have an SSL virtual host enabled.

Try enabling it:

a2ensite default-ssl

Be sure to reload Apache's configuration once you've done so:

service apache2 reload
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.